Advanced Excel 2007

One major organizational change in Excel 2007, when compared to 2003, is the introduction of ribbons. Each ribbon reveals many more options depending on what tab is selected. The “Help” button is the question mark at the far right. The Windows Button on the left replaces “File”.

The options under the “Get Started” tab provide some helpful starting points. The “Interactive Guide” is especially helpful in finding the commands you knew in 2003 in 2007.

It is a good idea when saving to make sure that you save your work as “Excel 97-2003 Workbook”. This ensures that the document will work with both older and current versions of Excel.

Selecting and Navigating Cells

- Holding **shift** while clicking or using the arrow keys selects the cells.
- **Ctrl + arrow key** jumps to the last cell containing data. For large worksheets, you can leave landmarks (like a period) in end cells to jump to. Ctrl and also be combined with shift.
- **Named cells and ranges** allow you to refer to a group of cells by a text name in formulas: (A1:A345)→(Monthly Rental). Not only does this help with organization, but as range changes, formulas stay correct.
• Creating a name: select desired range/cell. Type a name in name box (where cell reference is displayed, left of the formula bar). The name cannot start with a number or contain spaces. Press enter. Next to the name box, there are arrows for a drop down menu for other named cells. Selecting a name from this menu will select the cells in the worksheet.
• Pressing F5 will open the Go To box. Selecting the desired name will select the referenced cells.
You cannot delete or redefine a name using the name box. You need to use “define names group” on the formulas tab. Here you can change the name, limit its scope, or use text of surround cells to create name.

• Entering Data: F2 will allow you to type directly into the selected cell, without overwriting it.

**Formatting**

**Formatting Tables:**

You can choose different styles for your data (when organized in a rectangular format) by using the “Home”→*Styles*→*Format as Table*. Putting your data into a table allows you to quickly give it attractive color and font, as well as easy access to sorting and text filters (the arrows at the tops of the columns). Grabbing the bottom right corner allows you to add new rows (but no columns) in the selected table style. To remove the table format while keeping the table’s appearance, click anywhere in the table. This opens the “Design” tab. Choose “convert to range”.

**Conditional Formatting:**

Conditional Formatting allows you to automatically produce special cell formatting when certain specified conditions apply (ex: all subtotals in bold or all values over $1,000 in red italics).

To apply Conditional Formatting:

1. Select the desired range of data. Make sure all values fall under your criteria, or the result will appear skewed.
2. “Home”→*Styles*→Conditional Formatting
3. Select the type of condition you want to test for.
4. Excel executes the condition.
Conditional Formatting takes precedence over manual formatting. You can apply as many rules as you want, but be aware that conflicting rules may end up displaying unwanted formatting. To create custom rules, select New Rule under Conditional Formatting. To manage or clear existing rules, select Clear Rules or Manage Rules. When Conditional Formatting is applied to a table, it also applies to cells added to the table later. This also applies to new data entered directly below the data with conditional formatting.

**Presenting Worksheets**

**Copying a Worksheet as a Template:**

It can save time to use an existing worksheet as a template for new work. This way you can preserve desired formats, formulas, and/or data.

1. Select cells to be copied (for the whole sheet, do [ctrl + a]). Copy—[ctrl + c]. Open new worksheet and paste.
2. Delete all variable data, leaving labels and formulas. (To avoid deleting formulas, press [Ctrl + '] to make them visible. To hide the cell formulas again, press [Ctrl] + ['] again.)

**Exploring Data**

**Filtering Data:**

Filtering lets you explore data in Excel by allowing you to view only the data that meets your chosen criteria; i.e., to be able to have your worksheet only show the records for subjects who are less than 16 years old, or for which a certain value is negative.

1. To filter your data, highlight the columns you want to filter, and under the “Data” tab select “Filter”.
2. Down arrows appear at the top of selected columns – clicking on the arrows presents a drop down menu with filtering options.
3. The rows numbers with the filtered data appear blue.
4. To get rid of the filter, select “clear filter from...” in the filter drop down menu.

**Sorting Data:**

You can rearrange your data according to capital/lower case letters, cell contents (alphabetical order), cell color, font color, or cell icon. You also have the option of making a custom sort, which combines several sorting conditions at once. First highlight the desired data, then apply “Sort”. The sort option is found under the “Home” or “Data” tab. Unlike the filtering option,
sort is a one-time application that does not leave the arrows marking drop down menus at the tops of the columns.

Retrieving External (non-excel) Data into Excel:

Under the “Data” tab, there is a section called “get external data”.

Other Spreadsheet Programs:

Excel can directly open files from these programs. In Excel, go to the Windows Button → OPEN and in the Open box, select the appropriate file format in the Files of Type box.

Other Data Sources:

Data from other sources should be saved as ASCII text files. Excel can then open these text files with the Text Import Wizard.

1. Go to Windows Button → OPEN
2. In the Open box, select ‘Text Files’ or ‘All Files’ in the Files of Type box.
3. Click OK.
4. The Text Import Wizard will appear. Follow directions and answer questions in the Wizard to put data into Excel format.

Formulas

- When building a formula, a semicolon between two cell references means all the cells between the two references. A1:A27
- Excel follows the mathematical order of operations, so including different elements within parentheses may be useful. =(A1+C6)/D7
- [ctrl + ‘] will reveal formulas. Press again to hide.

Relative and absolute cell references

- **Relative:** If you copy the formula for a range of data and paste it in another cell, that copied formula will reference the new location. For example, if the formula in the original cell summed the three cells to its left, then the new copied cell will sum the three cells left of it.
- **Absolute:** Making a cell reference absolute means regardless of the where the formula is placed, it will always reference that cell. If the referenced cell is moved, the formula will adjust. To make an absolute cell reference, add “$” in front of the row/column identifier to keep desired row, column, or both. “$A1” will maintain its column but not the row. Press F4 to cycle through possible references ($A$1, A$1, $A1, A1).
Cell references outside of your worksheet:

- **Formulas referencing other sheets**: When ready to add in the reference from the other sheet into your formula, click on desired worksheet and select the cell. Press “enter”. 
  \( =\text{’name_of_other_sheet’!C12} \) (cell reference).
- **Linking to other workbooks**: Open both workbooks. When ready to add in the reference from the other sheet into your formula, click on desired worksheet and select the cell. Press “enter”. 
  \( =\text{’[Filename.xls]Sheetname’!A1} \)
- **Linking to multiple sheets**: When ready to add in the references from the other sheets into your formula, hold SHIFT and select tabs and then select cell/range. 
  \( =\text{Sheet2:Sheet23!A5} \)

**Paste Special**: Cells that contain formulas can be copied and pasted so that the values contained in the cells, and not the formulas, are copied. Copy the desired cell, select location to paste and then go Paste ➔ Paste Special. This will open up the Paste Special dialog box, check the ‘Values’ box, and then OK. Paste Special is also useful for other selective copying needs.

The **Formula Wizard** can help you apply more advanced formulas by allowing you to browse for the appropriate function, fill out the function by defining the cell references of each of its components, and applying it to your data. To access the Formula Wizard: open the drop down menu of the Autosum button under “Home” or “Formulas” tab, or by clicking “Insert Function” under “Formulas”. You can either type in a description of the formula you want, or browse the different categories.

**Some useful formulas:**

- **PMT**: Calculates the payment for a loan based on constant payments and a constant interest rate. Make sure interest rate and time period are expressed in the same units.
- **if/then conditional statements**: The IF function returns one value if a condition you specify is “true”, and another value if that condition “false”. For example, if the total of your monthly budget exceeds $1000 (bad!!), it may read “DEBT”. If it is under $1000, it may read “SAFE”. It uses value comparison: not equal, less than or equal to, greater than or equal to. To display a blank cell, make two quotation marks: “”.
- **countA ➔counts text**
- Excel maintains numbers to many decimal points (over 10), even if you changed the cell’s formatting to display only two. In calculations, it uses the long form of the number.
This, over many numbers or calculations, may display what seems to be calculation errors. You can customize the way Excel rounds numbers in formulas:

=round/rounddown/roundup/trunc

**Excel Charts**

1. Select data range (must be in rectangular format)
2. Under the “Insert” tab, you will see different chart options. Select an appropriate chart.
3. Excel will insert the chart onto the worksheet. The data referenced in the chart will be outlined in color.
4. You can further customize the chart by clicking on the chart. This makes the Chart Tools options appear at the top of the screen.

**Exporting Excel Data and Charts**

Exporting Excel Data and Charts to MS Word and MS PowerPoint:

1. In Excel, select the range or chart you want to copy, then under the “Home” tab, choose or press “ctrl + c”.
2. In Word or PowerPoint, click where you want to insert the Excel data.
   - Click **Microsoft Excel Worksheet Object** to paste the data as a picture that you can resize and position. By double clicking on the data, you can edit and reformat the data using Excel functions and tools.
   - Click **Formatted Text (RTF)** to insert in a form you can resize and reformat using Word or PowerPoint functions and tools. (In Word, this will insert the data in a Word table).
   - Click **Unformatted Text** to paste the data as text separated by tabs.

Exporting Excel Data and Charts to the Internet:

Click a cell in the data (or click on the chart) that you want to convert to a Web page. Go to the Windows Button→Save As→Other Formats. Under “Save as type”, choose “Single File Web Page”. You can also choose to save the entire workbook or a selected sheet. The “Change Title” option allows you to specify what will appear in the browser window.

**Multiple Sheets**
To **change the order** of the sheets, click and drag the sheet tabs in the order you want.

To **rename** the title of the sheet tab, double-click on the name.

To **add or delete a sheet**, right-click on a sheet tab to view the drop down menu.

To **edit multiple similar sheets at once, group the sheets**: select first sheet. Hold “ctrl” and click on additional sheet tabs. Any changes are applied to all sheets. To **ungroup**: right-click on a tab and select “ungroup”.

**Printing**

Excel will automatically prepare to print your work portrait style (up and down), showing only the entered data, keeping only the formatting of the data. This means that gridlines and row/column headings do not appear. If your data would better fit lengthwise, change the paper orientation to landscape.

To **change the paper orientation**: under the page tab, you can choose between portrait and landscape. This is also where you can scale up or down your work.

To **adjust margins and position on paper**: under “Margins”.

To **print gridlines and row/column headings**: under the “Sheet” tab

**Useful Shortcuts and Tips**

The Microsoft website offers a database of excel shortcuts:


here are a few basic ones:

[alt] will bring up letters you can enter from your keyboard to navigate the Ribbon.

[Ctrl + arrow key] will just to the last cell containing data. You can combine this with [shift] to select.

[F2] will allow you to type directly into the selected cell or, if the cell contains a formula, reveal the referenced cells.

[ctrl + ‘] will reveal formulas. Press again to hide.

[ctrl + 1] will open the cell formatting box.
[ctrl + a] selects the whole sheet.
[ctrl + g] returns you to the first cell in the sheet.

[ctrl + c] copies
[ctrl + v] pastes.
[ctrl + z] undo
[ctrl + y] redo

Placing an apostrophe before a number allows it to be read as text (and free from number formatting).

Help

Excel Help menu: you can either press the Help button 🔄 (which is at the end of the Ribbon) or press [F1].


Google is an amazing resource. Be specific when you search (i.e. “Excel 2007 remove conditional formatting”) and you almost always get a helpful response.

Techcons & Peer-to-Peer teachers: We can be found in the Infocommons and the MEWS. If we don’t know the answer we know someone else who does!